Android 14-ում հնարավոր չի լինի հին հավելվածներ տեղադրել՝ նույնիսկ APK-ի միջոցով

26 հունվարի, 2023  10:25

Android 14-ն ամբողջությամբ կարգելափակի օպերացիոն համակարգի հնացած տարբերակների համար նախատեսված հավելվածների տեղադրումը։ Սա կարող է օգնել օգտատերերին բազմաթիվ վնասակար ծրագրերից պաշտպանելու հարցում:

Google Play հավելվածների խանութը արդեն վաղուց ծրագրեր մշակողներից պահանջում է պարբերաբար թարմացնել իրենց հավելվածները անվտանգության վերջին պահանջներին համապատասխանելու համար: Բայց, փաստորեն, արդեն ներբեռնված հին հավելվածների մեծ մասը շարունակում է աշխատել օպերացիոն համակարգի նոր տարբերակներում, ավելին, օգտատերերը կարող են ձեռքով տեղադրել հնացած հավելվածները՝ օգտագործելով APK ֆայլերը։

Նոր Android 14-ում, որը նախատեսվում է թողարկել երրորդ եռամսյակում, հին հավելվածներն այլևս չեն կարող տեղադրվել նույնիսկ APK-ի միջոցով: Վերջերս հրապարակված կոդի փոփոխության մեջ երևում է, որ օպերացիոն համակարգի նոր տարբերակում կաշխատեն միայն այն հավելվածները, որոնք կունենան առնվազն Android 8-ի API-ի աջակցություն։

Ինչպես տեղեկացնում է 9to5google.com-ը, սկզբնական շրջանում Android 14 սարքերում կարգելափակվի միայն այն հավելվածների տեղադրումը, որոնք նախատեսված են Android-ի «հատկապես հին» տարբերակների համար։ Ավելի ուշ նախատեսվում է այդ շեմը բարձրացնել մինչև Android 6.0 (Marshmallow) և շարունակել այն բարձրացնել օպերացիոն համակարգի նոր տարբերակների թողարկմանը զուգահեռ: Հնարավոր է նաև, որ սարքերի յուրաքանչյուր արտադրող կարողանա ինքնուրույն ընտրել հին հավելվածների շեմը, որոնք կարող են տեղադրվել իր սարքերում:

Արգելափակելով հնացած հավելվածների տեղադրումը` Google-ը ցանկանում է զսպել վնասակար ծրագրերի տարածումը իր օպերացիոն համակարգում։ Բանն այն է, որ վնասակար շատ հավելվածներ հատուկ թիրախավորում են Android-ի ավելի հին տարբերակները, ինչը դրանց հնարավորություն է տալիս շրջանցել պաշտպանության այն միջոցները, որոնք ներկայումս կիրառվում են միայն ավելի նոր հավելվածների համար:

Նշենք, որ ցանկության դեպքում օգտատերերը, այդուհանդերձ, կկարողանան Android 14-ով աշխատող իրենց սարքերում հնացած հավելվածներ տեղադրել, սակայն դա պետք է արվի Command Line ծրագրի միջոցով: Նախ՝ շարքային օգտատերերի մեծ մասը չգիտի, թե ինչպես դա անել: Երկրորդ՝ քիչ հավանական է, որ ինչ-որ մեկը պատահաբար կամ սխալմամբ հնացած և պոտենցիալ վտանգավոր հավելված տեղադրի:


 
 
 
 
  • Արխիվ